mtl-compat v0.2.1 Release Notes

    • 💅 Require use of transformers-compat-0.4 or greater when building with mtl-2.1.3.1 or earlier. transformers-compat-0.4.0.* adds the missing ExceptT instances, which means that mtl-compat's only purpose is to backport the Control.Monad.Except module for those who want an mtl-style import for ExceptT and/or MonadError.

    I would recommend just using Control.Monad.Trans.Except from transformers-compat-0.4.0.* and Control.Monad.Error.Class instead, since they accomplish the same thing as mtl-compat without an extra dependency.