tasty-lua v0.2.3 Release Notes

Release Date: 2020-08-14 // about 1 month ago
    • ๐Ÿ— CI now also builds with for GHC 8.10.

    • Errors are now explicitly converted to strings before matched when using error_matches.

    • ๐Ÿ˜Œ Relax version limits for tasty and hslua, allowing tasty-1.3.* and hslua-1.2.*.


Previous changes from v0.2.2

    • โš  Avoid compilation warnings on GHC 8.2 and older. Monoid instances on older GHC versions require an explicit implementation of mappend. Newer instances use (<>) from Semigroup.

    • ๐Ÿ‘Œ Improved CI tests: build with more GHC versions, build with stack, and ensure that there are no HLint errors.