configuration-tools v0.4.0 Release Notes

Release Date: 2018-08-21 // almost 4 years ago
    • ๐Ÿ‘ Drop support for GHC < 7.10 and base < 4.8
    • ๐Ÿ‘ Drop support for Cabal < 1.24
    • ๐Ÿ‘ Drop support for transformers < 0.4
    • ๐Ÿ‘ท Don't run CI tests for Cabal < 2

    • ๐Ÿ“ฆ With Cabal 2.0 or later package info modules are placed in per component autogen directories. All package info modules are named just PkgInfo. For backward compatibility modules with the old legacy names (PkgInfo_*) are still generated but marked deprecated. With Cabal 1.24 only the legacy behavior is available and a deprecation warning is raised.